SUPPORTED BROWSERS


Make sure you are using a browser that Delogue PLM supports:
  • Chrome - from version 90
  • Firefox - from version 90 
  • Edge from version 90
  • Safari - from version 15

If you use other browsers - that Delogue PLM does not support, we cannot guarantee you that Delogue PLM will function correctly.


We no longer support Internet Explorer


RAM SETTINGS

We recommend a minimum 8 GB of RAM.